Atmosphère 1.7.0 disponible

Le développeur SciresM vient de sortir Atmosphère 1.7.0 La première prerelease de Atmosphère pour la 18.0.0


SciresM vient de posté une nouvelle version de Atmosphère, elle est la première version prerelease compatible avec le firmware 18.0.0

Changelog : 

1.7.0 est la soixante-dix-huitième version officielle d'Atmosphère.

Assurez-vous de mettre à jour fusee lors de la mise à jour vers la version 1.7.0. fusee-primary n'existe plus et ne fonctionnera plus.

Attention : Atmosphère 1.7.0 est actuellement en préversion, et des problèmes peuvent être trouvés qui doivent être corrigés avant la sortie de la version complète.

Si des bugs sont signalés pendant la préversion d'Atmosphère, ils seront corrigés et la version sera mise à jour.
La version 1.7.0 passera en release après un court laps de temps sans rapports de bugs pressants.
Grâce à l'équipe de @switchbrew, Atmosphère 1.7.0 est fourni avec hbl 2.4.4, et hbmenu 3.6.0.

Ce qui suit a été modifié depuis la dernière version :

- Le support de base a été ajouté pour la version 18.0.0.
- La console devrait démarrer et l'atmosphère devrait être pleinement fonctionnelle. Cependant, tous les modules n'ont pas été entièrement mis à jour pour refléter les derniers changements.
- Il ne devrait rien en résulter de visible pour l'utilisateur, mais ce problème sera abordé dans une prochaine mise à jour d'atmosphère, une fois que je ne serai plus autant en déplacement.
- exosphère a été mis à jour pour refléter le dernier comportement officiel du moniteur sécurisé.
- mesosphère a été mis à jour pour refléter le dernier comportement officiel du noyau.
- spl a été mis à jour pour refléter le dernier comportement officiel.
- fusee ne prend plus en charge l'application des correctifs IPS aux KIPs.
- Les seuls KIPs qui sont toujours présents sont a) les modules atmosphère, b) les modules système personnalisés, ou c) FS.
Le sous-système IPS a été conçu à l'origine pour faire fonctionner les correctifs nogc pour FS, mais ceux-ci sont maintenant internes, et il semble que les seuls correctifs littéraux kip qui existent sont pour le piratage.
Je n'ai pas trouvé de patchs kip affichés quelque part et destinés à d'autres fins.
Cela n'a fondamentalement aucun sens de ralentir le démarrage pour tous les utilisateurs normaux pour une fonctionnalité qui n'a pas d'utilité réelle, en particulier lorsque fusee cherche à être un chargeur de démarrage minimal.
- Des améliorations mineures ont été apportées à gdbstub d'atmosphere, notamment :
- Le support de QStartNoAckMode a été ajouté.
- Un problème qui pouvait provoquer une erreur fatale lors de la création d'un trop grand nombre de points d'arrêt a été corrigé.
- Un certain nombre de problèmes mineurs ont été corrigés et des améliorations ont été apportées :
- pt-BR (PortugueseBr) est désormais accepté comme une langue valide lors de la modification des paramètres locaux du jeu.
- Un bogue a été corrigé qui pouvait amener atmosphere à sérialiser incorrectement les ID des objets de sortie sur IPC lors de l'utilisation d'objets de domaine.
- Un bug a été corrigé dans la logique d'augmentation de la limite de ressources de pm qui pouvait potentiellement faire échouer des augmentations légitimes dans certaines circonstances.
- loader/ro lancera désormais une erreur fatale lors de l'utilisation de patchs IPS invalides qui sortent des limites, au lieu de corrompre la mémoire.
- La prise en charge a été corrigée pour le démarrage en utilisant une configuration de mémoire de la moitié de la mémoire réellement disponible (par exemple, forcer une configuration de 4 Go sur une carte de 8 Go).
Améliorations générales de la stabilité du système afin d'améliorer l'expérience de l'utilisateur.
Pour plus d'informations sur les fonctionnalités supportées par la version 1.7, veuillez consulter les notes de version officielles.

Lien de téléchargement : Atmosphère 1.7.0


Veuillez vous connecter ou vous créer un compte pour commenter cet article !


Il n'y a aucun commentaire pour le moment.